Helpful Posts Helpful Posts:  0
Results 1 to 2 of 2

Thread: Epson 1400 printer won't recognize cartridge

  1. #1

    Join Date
    Feb 2013
    New York, NY, USA

    Epson 1400 printer won't recognize cartridge

    I tried to put a new ink cartridge (Epson brand). I get a red X on the cartridge in the dialog box. I have tried with two different cartridges and the same result. The Ink Replacement Utility dialog box is saying the the cartridge is not compatible. 1) Is there something wrong between the cartridge and the printer or 2) Do I have a non-OEM cartridge even though it is supposedly OEM. Yes, I bought it on Ebay but I have been buying OEM cartridges on Ebay for years and never had a problem.

    Any ideas for solutions?

  2. #2

    Join Date
    Jan 2009
    South Devon, UK

    Re: Epson 1400 printer won't recognize cartridge

    I suppose the obvious next check is to purchase an absolutely genuine full price Epson cartridge from a reliable shop and try that.

    Genuine Epson cartridges can be refilled with non Epson ink. Does that cartridge have a chip which needs to be correctly identified as being new Epson?

    I use the R1900 and always fit real Epson cartridges from the cheapest guaranteed supplier.

    But there are so many simple errors which can occur. I assume the cartridges are correctly snapping into place, and you haven't done anything really silly like leaving the protective tape over the cartridge nozzle.

    I have had a rejected cartridge once but when I reinserted it everything was fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts