Results 1 to 5 of 5

Thread: Battery for Canon 5d mach 3 won't fully charge

  1. #1
    New Member
    Join Date
    Apr 2013
    Posts
    4

    Battery for Canon 5d mach 3 won't fully charge

    Hi--

    I have two batteries for my camera, a Canon LP-E6 that came with it, and a third-party Lenviar DLCE6. Both recharge, but the Lenviar recently only charges to about 76%. The charging unit green light comes on and I've even left it for a while longer, but that is the maximum charge I can get. The Canon charges to 100% all the time. Do I need to let the Lenviar fully discharge before recharging, or is this just what I'll need to accept from using a third-party battery?

    New to this forum. Will appreciate any help. Thanks.

    Bob

  2. #2
    Moderator GrumpyDiver's Avatar
    Join Date
    Mar 2012
    Location
    Ottawa, Canada
    Posts
    12,354
    Real Name
    Manfred Mueller

    Re: Battery for Canon 5d mach 3 won't fully charge

    There is an old saying that you get what you pay form and if you go for off-brand, you are taking your chances. These batteries are Li-ion batteries, so full (deep) discharge is not a great ideas this can damage this type of batteries. It does sound like you have had this battery for some time, because this type of behaviour can occur in new batteries, but tends to disappear after a few charge cycles.

  3. #3

    Join Date
    Jun 2013
    Location
    Victoria, Canada
    Posts
    78
    Real Name
    David

    Re: Battery for Canon 5d mach 3 won't fully charge

    mach 3 is pretty fast for a camera...
    about 2100 miles per hour.

  4. #4

    Join Date
    Jun 2013
    Location
    Victoria, Canada
    Posts
    78
    Real Name
    David

    Re: Battery for Canon 5d mach 3 won't fully charge

    mach 3 is pretty fast for a camera...
    about 2100 miles per hour.

  5. #5

    Join Date
    Nov 2008
    Location
    Lincolnshire,UK
    Posts
    148

    Re: Battery for Canon 5d mach 3 won't fully charge

    Quote Originally Posted by rwbass View Post
    Hi--

    I have two batteries for my camera, a Canon LP-E6 that came with it, and a third-party Lenviar DLCE6. Both recharge, but the Lenviar recently only charges to about 76%. The charging unit green light comes on and I've even left it for a while longer, but that is the maximum charge I can get. The Canon charges to 100% all the time. Do I need to let the Lenviar fully discharge before recharging, or is this just what I'll need to accept from using a third-party battery?

    New to this forum. Will appreciate any help. Thanks.

    Bob
    What Manfred says; if you go third party you run the risk of getting burned ... that can be literal in some cases. I don't joke here.

    You have paid good money for a good brand of camera which depends on getting a reliable power source. Yes, some third party brands can be good but at the slightest problem is Canon or the third party manufacturer going to have any interest in your problem? Most likely not.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •