Helpful Posts Helpful Posts:  0
Results 1 to 8 of 8

Thread: 430 Speedlite FEC

  1. #1
    Ramblinman's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, New York
    Posts
    164
    Real Name
    Paul

    430 Speedlite FEC

    I have a weird problem with my 430 ex speedlite flash where I cannot change the FEC on it at all. Does anyone have any advice on how to reset the settings or if I am doing something wrong that is preventing me from changing the FEC?

  2. #2

    Join Date
    Jan 2009
    Location
    South Devon, UK
    Posts
    11,264

    Re: 430 Speedlite FEC

    I have had something similar on occasions, Paul, but turning everything off seems to reset so I can start again. I think it is some confusion between that setting wheel and my brain which causes my problems.

    However, can we assume that you haven't set any custom functions on the camera? Are you making adjustments with the actual flash unit and not the camera controls? Are you using ETTL metering and not manual controls? Does the flash work OK otherwise?

    And what is showing, if anything, on the display screen?

    I can't find anything specific in my instruction book, although I have the 580 version.

  3. #3
    herbert's Avatar
    Join Date
    Oct 2010
    Location
    Sussex, UK
    Posts
    471
    Real Name
    Alex

    Re: 430 Speedlite FEC

    Also note that FEC does not work on Auto or Creative Auto modes. You have to be in Av, Tv or Manual mode.

    Alex

  4. #4
    Ramblinman's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, New York
    Posts
    164
    Real Name
    Paul

    Re: 430 Speedlite FEC

    I pored over all of my camera settings and the custom settings and I didnt have anything specific set. I determined that there is something wrong with the flash itself. I can change the FEC settings through the camera but even when I have the flash disconneced from the camera, I cant change the FEC. Even in Manual mode, I cant change the flash from 1/1. I put in ticket with Canon to see if there is anything else I can do. The only settings I use on the camera is either Manual mode or Av.

  5. #5

    Join Date
    Jan 2009
    Location
    South Devon, UK
    Posts
    11,264

    Re: 430 Speedlite FEC

    Just been experimenting with my 580 flash unit and I can get myself into a confused position which is similar to what you mention. Although I'm not quite sure what I am doing.

    Firstly, is the Set button, in the middle of the adjustment wheel operating correctly?

    I am finding a position where I select the Flash Exposure Bracket by pressing the Set Button twice and I can't then go directly to the FEC adjustment.

    I need to press Set twice more before that can happen. And I also get something similar if I try to adjust the Zoom setting and then the High Speed flash option I end up needing to press Set up to 4 times before I can access FEC again.

    Not sure if something along these lines is what you are experiencing; but it has certainly baffled me a few times previously when I needed to quickly make changes.

    I'm still not certain that I understand the flash menu options; but it does appear that if you press Set enough times it is possible to find the required setting. But I don't always seem to recognise when I have reset everything to the default position.

    This has been an interesting question which has started me looking at my flash options in greater detail - although I can't really say that I fully understand everything.

  6. #6
    Ramblinman's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, New York
    Posts
    164
    Real Name
    Paul

    Re: 430 Speedlite FEC

    Quote Originally Posted by Geoff F View Post
    Just been experimenting with my 580 flash unit and I can get myself into a confused position which is similar to what you mention. Although I'm not quite sure what I am doing.

    Firstly, is the Set button, in the middle of the adjustment wheel operating correctly?

    I am finding a position where I select the Flash Exposure Bracket by pressing the Set Button twice and I can't then go directly to the FEC adjustment.

    I need to press Set twice more before that can happen. And I also get something similar if I try to adjust the Zoom setting and then the High Speed flash option I end up needing to press Set up to 4 times before I can access FEC again.

    Not sure if something along these lines is what you are experiencing; but it has certainly baffled me a few times previously when I needed to quickly make changes.

    I'm still not certain that I understand the flash menu options; but it does appear that if you press Set enough times it is possible to find the required setting. But I don't always seem to recognise when I have reset everything to the default position.

    This has been an interesting question which has started me looking at my flash options in greater detail - although I can't really say that I fully understand everything.
    Yes, Im talking about the Set button and the + and - buttons on either side of it. When I first got the flash, I was able to change the FEC without any problems. Now, over the past 6 months, I have noticed that it started working less and less and now its gotten to a point where it doesnt work at all. At first, I thought it was some settings I set on the the flash itself, but I never played with the custom functions on it since I didnt know what settings it would change. All the custom functions on the camera are OK as well. I removed the batteries for about 10 minutes but that didnt help matters at all.

    Holding down the set button, and the + and - doesnt result in any positive results. Nothing happens, so I came to the conclusion that its the flash itself, not any custom settings on the flash or camera itself.

  7. #7

    Join Date
    Jan 2009
    Location
    South Devon, UK
    Posts
    11,264

    Re: 430 Speedlite FEC

    Well we seem to have exhausted all the simple ideas then.

    It does now appear likely to be a unit fault. Is it still under guarantee? If not I'm afraid that repair costs could be as much as a new unit.

  8. #8
    Ramblinman's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, New York
    Posts
    164
    Real Name
    Paul

    Re: 430 Speedlite FEC

    Quote Originally Posted by Geoff F View Post
    Well we seem to have exhausted all the simple ideas then.

    It does now appear likely to be a unit fault. Is it still under guarantee? If not I'm afraid that repair costs could be as much as a new unit.
    I submitted a ticket with canon and waiting to hear back from them them and see what they say.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •