Helpful Posts Helpful Posts:  0
Results 1 to 4 of 4

Thread: Lens problem (Canon 70-200 f4)

  1. #1
    speedneeder's Avatar
    Join Date
    Nov 2010
    Location
    Owensboro, KY
    Posts
    1,532
    Real Name
    Brian

    Lens problem (Canon 70-200 f4)

    I noticed yesterday that ther are some 'streaks' on the front element. It looks like when you clean a lens and some streaks are left from the cleaning solution. I tried to clean the lens again (with targus lens cleaner) and it helped, but did not eliminate the streaks. I can't tell any difference from the lens photos, but I was wondering if I'm missing some lens cleaning basic????

  2. #2

    Join Date
    Dec 2008
    Location
    New Zealand
    Posts
    17,662
    Real Name
    Have a guess :)

    Re: Lens problem (Canon 70-200 f4)

    Hi Brian,

    Try a microfibre cloth and some "L-Breath" - it's all I ever use.

    And when you do get it clean, have a think about a UV filter - they're a lot easier to clean

  3. #3

    Join Date
    Jan 2009
    Location
    South Devon, UK
    Posts
    11,710

    Re: Lens problem (Canon 70-200 f4)

    Just a silly thought. Are they definitely on the outside and not on the inside where condensation could be the cause.

    Otherwise I suppose it may be something which has dried hard and will need a bit of a 'soaking' with lens cleaning fluid to soften it.

  4. #4
    speedneeder's Avatar
    Join Date
    Nov 2010
    Location
    Owensboro, KY
    Posts
    1,532
    Real Name
    Brian

    Re: Lens problem (Canon 70-200 f4)

    Hi Geoff, Definitely on the outside. I will try some soaking and see if that helps. Thanks for your suggestion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •