Helpful Posts Helpful Posts:  0
Results 1 to 9 of 9

Thread: Issues with Sigma 17 - 70mm lens

  1. #1
    Karl's Avatar
    Join Date
    Sep 2011
    Location
    Rockingham, Western Australia
    Posts
    178
    Real Name
    Karl

    Issues with Sigma 17 - 70mm lens

    Just wondering if anyone here uses this lens and has had any issues with it?

    I bought mine earlier in the year for my Canon 7D but I have a lot of issues with soft images - even though the red squares light up in the lens and I get the green focus confirmation in the camera's view finder.

    Sometimes I get a nice sharp image but more often than not the image is very soft and sometimes to the point of looking like it is just out of focus

    I have sent an email back to the place I bought it from and I am waiting their response but I was just interested if this is a one off case or have others had the same?

    Karl

  2. #2
    dje's Avatar
    Join Date
    May 2011
    Location
    Brisbane Australia
    Posts
    4,148
    Real Name
    Dave Ellis

    Re: Issues with Sigma 17 - 70mm lens

    Hi Karl

    I use this lens all the time on my 600D and am quite happy with it. Maybe there is a problem with your particular lens or maybe there's a calibration issue on your auto focus between the 7D and the lens. You could try some tests with one of those charts you place at 45 degrees. They are supposed to show up front or back focus issues. Or you could also try a comparison between AF in phase detect mode (using the viewfinder and the dedicated AF sensors) and AF in contrast detect mode (using Live View mode which is on the main sensor). Make sure you do it in a controlled environment with a test chart of some sort and with AF set to manual centre point selection.

    You could also try a manual focus in Live View mode with the screen view magnified. This should demonstrate whether good focus is possible and may prove that there is a problem with the AF.

    Dave
    Last edited by dje; 16th August 2013 at 02:34 AM. Reason: Extra info added

  3. #3
    davidedric's Avatar
    Join Date
    Jul 2012
    Location
    Cheshire, England
    Posts
    3,042
    Real Name
    Dave

    Re: Issues with Sigma 17 - 70mm lens

    I have the same set up as Dave, with the lens on a 600D body, and I have not had any problems with softness.

    (another) Dave

  4. #4
    Karl's Avatar
    Join Date
    Sep 2011
    Location
    Rockingham, Western Australia
    Posts
    178
    Real Name
    Karl

    Re: Issues with Sigma 17 - 70mm lens

    Dave & Dave,

    Thanks for that. I have tried a number of different tests and get the same sort of results - the odd sharp one but mostly soft.

    I bought it from B&H in New York and they have advised me to contact Sigma (USA I presume) so I am waiting on contact details - i.e. email - so I can contact them.

    Karl

  5. #5
    New Member
    Join Date
    Nov 2012
    Location
    Indianapolis
    Posts
    3
    Real Name
    Guy

    Re: Issues with Sigma 17 - 70mm lens

    Karl, have you solved the issue? I just ordered the Sigma zoom (in its 3rd version called contemporary) but have not received it yet. Am curious of the Sigma US reply.

  6. #6
    xpatUSA's Avatar
    Join Date
    Feb 2012
    Location
    Texas
    Posts
    2,949
    Real Name
    Ted

    Re: Issues with Sigma 17 - 70mm lens

    Karl, I have the older pre-HSM version and I find it a little soft on a Sigma SD9. On that lens version, the focus ring only has about a 1/4 turn range so focusing is a bit finicky and that may be my problem. http://slrgear.com/reviews/showcat.php/cat/31 (pick yours) says it's quite a sharp lens in focal length mid-range.

  7. #7
    Karl's Avatar
    Join Date
    Sep 2011
    Location
    Rockingham, Western Australia
    Posts
    178
    Real Name
    Karl

    Re: Issues with Sigma 17 - 70mm lens

    Hi all,

    I put the lens in for a service / check up and they could find no issues with it. One of my friends has suggested put the lens on the Canon 7D and do a 'micro auto focus' adjustment for this particular lens as it may just be an isse between the camera and lens. So I will see how I go - fingers crossed

    Karl

  8. #8
    Stagecoach's Avatar
    Join Date
    Jun 2012
    Location
    Suva, Fiji
    Posts
    5,588
    Real Name
    Grahame

    Re: Issues with Sigma 17 - 70mm lens

    Karl,

    If it was mine the first thing I would do after getting it back is put it on a tripod using every possible option available to 'assist' sharpness as mirror up, remote release, timer, base ISO and supposed sweet spot to eliminate hand holding possible movement. Find a static subject with good sharp definition and contrast and use manual focus to see if you can actually achieve acceptable and consistent sharpness.

    This will at least confirm if it's capable of acceptable results. If it's not, fine tuning autofocus is not going to solve the problem.

    Grahame

  9. #9
    Karl's Avatar
    Join Date
    Sep 2011
    Location
    Rockingham, Western Australia
    Posts
    178
    Real Name
    Karl

    Re: Issues with Sigma 17 - 70mm lens

    Hi Grahame,

    Thanks for that - have been doing a lot of research and I think I need to really look at calibrating the lens to the 7D, will see how I go.

    Karl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •