Helpful Posts Helpful Posts:  0
Results 1 to 7 of 7

Thread: Stuck Pixels? Digital Noise?

  1. #1
    ktuli's Avatar
    Join Date
    Mar 2011
    Location
    Pittsburgh, PA
    Posts
    1,518
    Real Name
    Bill S

    Stuck Pixels? Digital Noise?

    I'm processing some semi-long exposure photos tonight and when I first open the RAW file, I am seeing what I would classify as 'stuck pixels' Always a single color (either red, green, or blue) and perfectly round each time. I think they're also in an exact pattern every time (though sometimes certain ones don't appear - I think it depends on the exposure time).

    The weird thing is though - after a bit, they disappear from the RAW file. I can usually zoom in on them and look at them, but when I zoom back out, they vanish.

    Is this digital noise? Stuck pixels? Is this something I should be concerned with or natural?

    I've never really noticed this before, but maybe I just wasn't paying attention.

    - Bill

  2. #2

    Join Date
    Nov 2011
    Location
    San Diego, CA
    Posts
    152

    Re: Stuck Pixels? Digital Noise?

    My guess would be - your SW is working to automatically remove those.
    While it's working you can see them. When it's done - you can't.
    If they really truly disappear - I wouldn't worry about them. All DSLR sensors have those.

  3. #3

    Join Date
    Dec 2008
    Location
    New Zealand
    Posts
    17,662
    Real Name
    Have a guess :)
    ACR / Bridge follows this behaviour. They're visible in Bridge, but most disappear within a few seconds of opening them in ACR.

  4. #4
    Glenn NK's Avatar
    Join Date
    Sep 2010
    Location
    Victoria BC
    Posts
    1,510

    Re: Stuck Pixels? Digital Noise?

    Bill:

    What camera do you have? A few years ago, several people on a Canon forum mentioned that there was a method to fix/reduce these pixels, and many people had some success.

    The method: turn camera on, select "Sensor cleaning", and activate (but leave the lens cap on). No, I'm not crazy - the older Canons (10D, 20D, 30D) do not have sensor cleaning. Sensor cleaning was used to swing the mirror up and open the shutter, leaving access to clean the sensor with a blower or swab. For some reason, it usually worked for these older models. It might even work for newer ones - I don't know. Have no idea if it works for other brands.

    Glenn

  5. #5

    Join Date
    Dec 2008
    Location
    New Zealand
    Posts
    17,662
    Real Name
    Have a guess :)

    Re: Stuck Pixels? Digital Noise?

    Off memory Glenn, I think it was more "urban legend" than anything else. As far as I know, the only way to have hot pixels mapped out is for Canon to do it as part of a service.

  6. #6

    Re: Stuck Pixels? Digital Noise?

    Exactly the same thing is happening with my Canon 5D II and I'm wondering exactly the same things as you...should I be concerned?

    please direct any help to ahronrr@gmail.com !!

  7. #7
    Administrator Manfred M's Avatar
    Join Date
    Mar 2012
    Location
    Ottawa, Canada
    Posts
    13,634
    Real Name
    Manfred Mueller

    Re: Stuck Pixels? Digital Noise?

    Quote Originally Posted by Glenn NK View Post
    Bill:

    What camera do you have? A few years ago, several people on a Canon forum mentioned that there was a method to fix/reduce these pixels, and many people had some success.

    The method: turn camera on, select "Sensor cleaning", and activate (but leave the lens cap on). No, I'm not crazy - the older Canons (10D, 20D, 30D) do not have sensor cleaning. Sensor cleaning was used to swing the mirror up and open the shutter, leaving access to clean the sensor with a blower or swab. For some reason, it usually worked for these older models. It might even work for newer ones - I don't know. Have no idea if it works for other brands.

    Glenn
    In higher end video cameras this is done fairly commonly and is called "black balance". It's actually an automated function and is built right into the white balance button; which is just held down for a few seconds and the "ABB" jumps up in the viewfinder. It provides a new baseline for the camera to use and does reduce noise in shots. It could certainly identify hot pixels too. I've never heard about it for a still camera, but in theory, there is no reason why this functionality might just be an undocumented feature.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •