Helpful Posts Helpful Posts:  0
Results 1 to 4 of 4

Thread: 7D problem in Av, Tv & P modes - Help!

  1. #1
    whited3's Avatar
    Join Date
    Dec 2010
    Location
    Brisbane, Australia
    Posts
    422
    Real Name
    Mark

    7D problem in Av, Tv & P modes - Help!

    Hi Folks.

    Problem with the 7D. When I try to use Av, Tv or P mode via the viewfinder the shutter locks open for 30 seconds regardless of any other settings and no image is saved.

    These modes do work when using Liveview.

    I have reset the camera's setting with no effect. All other modes work properly.

    Any help would be appreciated.

    Cheers,

    Mark

  2. #2
    whited3's Avatar
    Join Date
    Dec 2010
    Location
    Brisbane, Australia
    Posts
    422
    Real Name
    Mark

    Re: 7D problem in Av, Tv & P modes - Help!

    Fixed. It was the "mirror lock up" function which I'd enabled after watching a 7D "how to" DVD I got for xmas. Still don't understand why it had this effect in these modes though.

  3. #3

    Join Date
    Oct 2010
    Location
    Greece (ex UK)
    Posts
    618
    Real Name
    Russell

    Re: 7D problem in Av, Tv & P modes - Help!

    Hi, I think your answer to what is happening is that when you set camera to mirror lockup you press the shutter button once to lock up and second time to take the photograph, I use on my 1Ds Mk II, the reasoning behind the double action required to fire the shutter is when you lock up the mirror you get vibration for a fraction of time and that is why you have to push the button twice.
    If I am wrong sure someone will give a better reply.
    Thanks
    Russ

    P.S. Forgot that when you use live view the mirror I believe locks up to allow this function when you finish live view it drops back automatic.
    Last edited by russellsnr; 7th January 2012 at 06:09 AM. Reason: Forgot!!

  4. #4
    whited3's Avatar
    Join Date
    Dec 2010
    Location
    Brisbane, Australia
    Posts
    422
    Real Name
    Mark

    Re: 7D problem in Av, Tv & P modes - Help!

    Thanks Russ, the double press worked fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •